hashem82eg

VIN decoder Indication wrong manufacture year, Report showing Year of manufacture: 2001 which is wrong ?? 😔😔 VIN: WDD2120341A997313

Continue Reading

TacoMan

When looking up the “Records” its showing lines with “F” and “O”. What does this mean? Also first open display of app showing the engine temp says MIL satus “off”. What is this and can i turn on? Thanks Works great on 2017 TRD Sport TACOMA

Continue Reading

Extreme1

http://aws.ithinkcar.com/Home/Index/shareReport/diagnose_record_id/f261e984sa1u3bKwDhAE/report_type/TC/l/en-us Help

Continue Reading

eric.w

## More, works GREAT!! 🙌

Continue Reading

eric.w

## Just a few of many vehicles, works GREAT!! 🙌

Continue Reading

LoWiTemp

Up and running in my 2007 Camry! #thinkcar #1s #firsttime

Continue Reading

jmj31685

Updated software and firmware. Plug the dongle into both a Ford and GM vehicle of early 00 vantage. The phone sees the dongle and the Aop appears to connect but then I get "Read dongle info failed, please replug and try again."

Continue Reading

Luis

good

Continue Reading

summer

http://aws.ithinkcar.com/Home/Index/shareReport/diagnose_record_id/3fa51e61sa1u3b8cAE54/report_type/TC/l/en-us?style=2

Continue Reading

jcapp

Does anyone want to buy my ThinkCar1s? It’s been a hard to get to work on my cars and I want to give it to someone who it will actually help.

Continue Reading

fergazer

Hi, anyone got it working on 2017 Subaru Outback 3.6?

Continue Reading

Benja

trying my first time full modules scan now 😆

Continue Reading

Benja

on board😁

Continue Reading

dchilds7

Can't get it to interface with my 2000 Pontiac Grand Prix... all ODB II protocols fail.... any hints on things to try?

Continue Reading

eric.w

2013 BENZ GLK 350, works good. http://aitus.golo365.com/Home/ThinkCar/reportDetail/diagnose_record_id/149fc9f0sa1u1utZoGAE/report_type/TC/l/en-us

Continue Reading